Search found 48 matches

by Craigus77
Mon Nov 30, 2015 6:56 pm
Forum: Technical help
Topic: REV3 - No spark
Replies: 7
Views: 31060

Re: REV3 - No spark

New CDI (thanks TRIALTECH) and we're back up and running again.

=D> =D> :beta =D> =D>
by Craigus77
Wed Nov 11, 2015 8:58 pm
Forum: Technical help
Topic: REV3 - No spark
Replies: 7
Views: 31060

Re: REV3 - No spark

Looks identical.. How much you thinking? :mrgreen:
by Craigus77
Thu Nov 05, 2015 7:57 pm
Forum: Technical help
Topic: REV3 - No spark
Replies: 7
Views: 31060

Re: REV3 - No spark

TRIALTECH wrote:yes, I have a brand new one for that model. ill post up a photo tonight for you to compare


=D>
by Craigus77
Thu Nov 05, 2015 10:17 am
Forum: Technical help
Topic: REV3 - No spark
Replies: 7
Views: 31060

REV3 - No spark

Hi All, Having an issue with my rev3 200. After a good fall a few weeks back it started to stall on and off during the day and at the end of the day stopped all together. I've tried all the simple fix's like new plug, removing kill switch, checked all wiring but there is no spark at all. Reading a l...
by Craigus77
Sat Aug 22, 2015 10:29 am
Forum: All about....me!
Topic: help please
Replies: 2
Views: 32811

Re: help please

Hi Ben, Tough question, I went though the same thing not so long ago. I was 110KG's and ended up on a BETA REV3 200cc and it's been perfect for learning. Very easy to ride with enough power to do everything I need without fear of it trying to kill me. I've since made it down to 85KG's and now having...
by Craigus77
Mon Aug 10, 2015 9:17 am
Forum: Pictures & Videos
Topic: n00b day
Replies: 8
Views: 45814

Re: n00b day

Not sure if anyone is looking at these.. But, another from the weekend :)

https://youtu.be/mdbrnA_QdW4
by Craigus77
Mon Aug 03, 2015 10:01 am
Forum: Pictures & Videos
Topic: n00b day
Replies: 8
Views: 45814

Re: n00b day

Getting heaps of time on the bike lately, don't think it'll be long before I look to a more modern bike :)

:beta

https://youtu.be/qz3XNA3yyHo
by Craigus77
Thu Jul 30, 2015 7:34 pm
Forum: Technical help
Topic: My BETA REV3 200
Replies: 35
Views: 39978

Re: My BETA REV3 200

Thanks for the feedback peeps.. Completly stripped down the carb, soaked in cleaner and blew out all components with compressor. Put it together and it's running great! :mrgreen: :mrgreen:

:beta =D>
by Craigus77
Sun Jul 26, 2015 5:37 pm
Forum: Technical help
Topic: My BETA REV3 200
Replies: 35
Views: 39978

Re: My BETA REV3 200

OK, so.. Today I removed the carb + stripped down, cleaned with carb cleaner and blew out with compressed air. Let it all dry and reinstalled. Same issue :(

I'm really at a loss now?? I've attached a video to try and demonstrate the issue better.

https://youtu.be/9YwwO1HOeI8
by Craigus77
Sat Jul 25, 2015 5:06 pm
Forum: Technical help
Topic: My BETA REV3 200
Replies: 35
Views: 39978

Re: My BETA REV3 200

Thanks man.. I figured as much but didn't really want to have to take the damn carb off it again. They are a pain the back-side to get back on! #-o

Go to advanced search