Techno 1994 Clutch

Got a technical question? Ask it in here.

Moderator: Moderators

escoe11
Junior participant
Junior participant
Posts: 8
Joined: Mon Jan 03, 2005 9:50 pm
Location: Moss Vale NSW

Techno 1994 Clutch

Postby escoe11 » Sun Oct 01, 2006 10:30 am

I have recently purchased a Beta Techno 1994 model and the problem I'm having is that the clutch does not work until the bike is hot. Bike mechanic said possibly wrong oil, but I have been using recommended Shell Light Gear Oil. It is fine once it is hot, but the bike runs really cool and sometimes the clutch doesn't work at the most innappropriate times.

Any ideas?

Thanks
Steve



User avatar
N*A*M
C grade participant
C grade participant
Posts: 39
Joined: Sun Jun 25, 2006 10:35 pm
Location: West Melb

Postby N*A*M » Mon Oct 09, 2006 5:39 pm

i have the same issue and i'm unsure how to remedy it.



motocentral
Dealer
Dealer
Posts: 121
Joined: Tue Feb 08, 2005 5:44 pm
Location: Canberra

Sticky Clutch

Postby motocentral » Tue Oct 10, 2006 8:47 am

Hi Steve, We have the same problem when we trade in some older bikes. What happens is the fibre clutch plates become impregnated over the years with old oil & this causes them to stick together. When the oil heats up it helps loosen up the plates & then they work ok. Easiest solution is to replace the clutch plates & then keep up the regular oil changes.
We have just started stocking the OEM clutch plates from Italy for these bikes. A pack of fibre plates for a Techno is $99 (original beta pack $150)
Hope that helps.
Trialzone 02-62480229


Play with Gravity


Return to “Technical help”

Who is online

Users browsing this forum: No registered users and 6 guests